Resolved
The problem has been resolved.
Monitoring
The fix has been deployed and we’re monitoring the results.
Identified
We’ve identified root cause of the issue where environment deletion operation in Saleor Cloud may fail.
We’re working on fixing the problem.