Saleor Cloud

Requests to Saleor Cloud in US region may return errors
Monitoring·Partial outage

We are currently observing significant recovery in the affected services. Our teams continue to monitor the situation closely. We will provide an update on full recovery in the next status communication.

Mon, Oct 20, 2025, 11:12 AM
(23 hours ago)
·
Affected components
Updates

Monitoring

We are currently observing significant recovery in the affected services. Our teams continue to monitor the situation closely. We will provide an update on full recovery in the next status communication.

Mon, Oct 20, 2025, 11:12 AM

Identified

We identified cause of failures in Saleor Cloud. Issues are caused by an external service provider (AWS) outage.

Mon, Oct 20, 2025, 07:22 AM(3 hours earlier)

Investigating

We're currently investigating the issue.

Mon, Oct 20, 2025, 07:15 AM